import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?::|^)((?:0+:){2,}0+)(?=:|$)|(?::|^)(0+)([0-9a-f]+)(?=:|$)|\\b0+([0-9a-f]{1,4})\\b";
final String string = "2001:0db8:abcd:0012:0000:0000:0000:0001\n"
+ "2001:0db8:abcd:0012:0000:0000:0000:00a2\n"
+ "2001:0db8:abcd:0012:0000:0000:0000:00ff\n"
+ "a:b:0:c:d:e:f:g\n"
+ "2001:0db8:abcd:0012:0000:0000:0000:0001\n"
+ ":00ff:0000:\n"
+ "0012:0000:0000:0000:0001";
final String subst = "${1:+::}${3}${4}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}