const regex = /\b(?:(?:0{2,}(:))+0*|0+\B)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:0{2,}(:))+0*|0+\\B)', 'gmi')
const str = `2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
a:b:0:c:d:e:f:g
2001:0db8:abcd:0012:0000:0000:0000:0001
:00ff:0000:
0012:0000:0000:0000:0001
0000:0000:0000:0000:0001
0000:0000:1234:0000:0000
0001:0000:0000:0000:0000`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);