$re = '/\b(?:(?:0{2,}(:))+0*|0+\B)/mi';
$str = '2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff
a:b:0:c:d:e:f:g
2001:0db8:abcd:0012:0000:0000:0000:0001
:00ff:0000:
0012:0000:0000:0000:0001
0000:0000:0000:0000:0001
0000:0000:1234:0000:0000
0001:0000:0000:0000:0000';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;