const regex = /(')(\<\?php echo L10n\:\:message\('dialog.delete', )(L10n\:\:label\()(.*?)(\); \?\>)(')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\')(\\<\\?php echo L10n\\:\\:message\\(\'dialog.delete\', )(L10n\\:\\:label\\()(.*?)(\\); \\?\\>)(\')', 'gm')
const str = `'<?php echo L10n::message('dialog.delete', L10n::label(MODULE)); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('client', true)); ?>'
'<?php echo L10n::message('dialog.delete', array('module' => L10n::label('frequency'))); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('file')); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('image')); ?>'`;
const subst = `'\<\?php echo $3$4; \?\>' + ' : ' + $1$2''\)\; \?\>'`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);