// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(')(\<\?php echo L10n\:\:message\('dialog.delete', )(L10n\:\:label\()(.*?)(\); \?\>)(')").unwrap();
let string = "'<?php echo L10n::message('dialog.delete', L10n::label(MODULE)); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('client', true)); ?>'
'<?php echo L10n::message('dialog.delete', array('module' => L10n::label('frequency'))); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('file')); ?>'
'<?php echo L10n::message('dialog.delete', L10n::label('image')); ?>'";
let substitution = "'\\<\\?php echo $3$4; \\?\\>' + ' : ' + $1$2''\\)\\; \\?\\>'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}