import re
regex = re.compile(r"(')(\<\?php echo L10n\:\:message\('dialog.delete', )(L10n\:\:label\()(.*?)(\); \?\>)(')", flags=re.MULTILINE)
test_str = ("'<?php echo L10n::message('dialog.delete', L10n::label(MODULE)); ?>'\n"
"'<?php echo L10n::message('dialog.delete', L10n::label('client', true)); ?>'\n"
"'<?php echo L10n::message('dialog.delete', array('module' => L10n::label('frequency'))); ?>'\n"
"'<?php echo L10n::message('dialog.delete', L10n::label('file')); ?>'\n"
"'<?php echo L10n::message('dialog.delete', L10n::label('image')); ?>'")
subst = "'\\<\\?php echo $3$4; \\?\\>' + ' : ' + $1$2''\\)\\; \\?\\>'"
result = regex.sub(subst, test_str)
if result:
print(result)