use strict;
my $str = '\'<?php echo L10n::message(\'dialog.delete\', L10n::label(MODULE)); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', L10n::label(\'client\', true)); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', array(\'module\' => L10n::label(\'frequency\'))); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', L10n::label(\'file\')); ?>\'
\'<?php echo L10n::message(\'dialog.delete\', L10n::label(\'image\')); ?>\'';
my $regex = qr/(')(\<\?php echo L10n\:\:message\('dialog.delete', )(L10n\:\:label\()(.*?)(\); \?\>)(')/mp;
my $subst = '\'\\<\\?php echo $3$4; \\?\\>\' + \' : \' + $1$2\'\'\\)\\; \\?\\>\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";