package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D+(\d+).*`)
var str = `filepath/23-00.xlsx`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}