const regex = /^\D+(\d+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\D+(\\d+).*', 'gm')
const str = `filepath/23-00.xlsx`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);