use strict;
my $str = 'filepath/23-00.xlsx';
my $regex = qr/^\D+(\d+).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";