$re = '/^\D+(\d+).*/m';
$str = 'filepath/23-00.xlsx';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;