#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\[\[title]](.*?)^$"
Local $sString = "[[title]]" & @CRLF & _
"a = "1"" & @CRLF & _
"b = "1"" & @CRLF & _
"c = "1"" & @CRLF & _
"d = "1"" & @CRLF & _
"e = [" & @CRLF & _
" "1"," & @CRLF & _
" "1"," & @CRLF & _
"]" & @CRLF & _
"" & @CRLF & _
"[[title]]" & @CRLF & _
"a = "2"" & @CRLF & _
"b = "2"" & @CRLF & _
"c = "2"" & @CRLF & _
"d = "2"" & @CRLF & _
"e = [" & @CRLF & _
" "2"," & @CRLF & _
"]" & @CRLF & _
"" & @CRLF & _
"[[title]]" & @CRLF & _
"a = "a3"" & @CRLF & _
"b = "3"" & @CRLF & _
"c = "3"" & @CRLF & _
"" & @CRLF & _
"[[title]]" & @CRLF & _
"a = "a4"" & @CRLF & _
"b = "4"" & @CRLF & _
"c = "4"" & @CRLF & _
"e = [" & @CRLF & _
" "4"," & @CRLF & _
"]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")