import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[title]](.*?)^$";
final String string = "[[title]]\n"
+ "a = \"1\"\n"
+ "b = \"1\"\n"
+ "c = \"1\"\n"
+ "d = \"1\"\n"
+ "e = [\n"
+ " \"1\",\n"
+ " \"1\",\n"
+ "]\n\n"
+ "[[title]]\n"
+ "a = \"2\"\n"
+ "b = \"2\"\n"
+ "c = \"2\"\n"
+ "d = \"2\"\n"
+ "e = [\n"
+ " \"2\",\n"
+ "]\n\n"
+ "[[title]]\n"
+ "a = \"a3\"\n"
+ "b = \"3\"\n"
+ "c = \"3\"\n\n"
+ "[[title]]\n"
+ "a = \"a4\"\n"
+ "b = \"4\"\n"
+ "c = \"4\"\n"
+ "e = [\n"
+ " \"4\",\n"
+ "]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}