using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[title]](.*?)^$";
string input = @"[[title]]
a = ""1""
b = ""1""
c = ""1""
d = ""1""
e = [
""1"",
""1"",
]
[[title]]
a = ""2""
b = ""2""
c = ""2""
d = ""2""
e = [
""2"",
]
[[title]]
a = ""a3""
b = ""3""
c = ""3""
[[title]]
a = ""a4""
b = ""4""
c = ""4""
e = [
""4"",
]
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}