// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)\[\[title]](.*?)^$").unwrap();
let string = "[[title]]
a = \"1\"
b = \"1\"
c = \"1\"
d = \"1\"
e = [
\"1\",
\"1\",
]
[[title]]
a = \"2\"
b = \"2\"
c = \"2\"
d = \"2\"
e = [
\"2\",
]
[[title]]
a = \"a3\"
b = \"3\"
c = \"3\"
[[title]]
a = \"a4\"
b = \"4\"
c = \"4\"
e = [
\"4\",
]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}