use strict;
my $str = '0.00
123.12k
123,123,123.12m
123,123,123,123.00b';
my $regex = qr/^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}