re = /^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$/m
str = '0.00
123.12k
123,123,123.12m
123,123,123,123.00b'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end