import re
regex = re.compile(r"^[0-9]{1,3}((\,[0-9]{3})*)\.[0-9]{2}[kmb]?$", flags=re.MULTILINE)
test_str = ("0.00\n"
"123.12k\n"
"123,123,123.12m\n"
"123,123,123,123.00b")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")