using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w+\-]){6,}";
string input = @""" 3 89 -90/ 900407-2""
"" 3 9 -90/ 900407-1""
"" 89 -9011/ 800408""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}