re = /([\w+\-]){6,}/
str = '" 3 89 -90/ 900407-2"
" 3 9 -90/ 900407-1"
" 89 -9011/ 800408"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end