// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([\w+\-]){6,}").unwrap();
let string = "\" 3 89 -90/ 900407-2\"
\" 3 9 -90/ 900407-1\"
\" 89 -9011/ 800408\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}