const regex = /([\w+\-]){6,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w+\\-]){6,}', 'g')
const str = `" 3 89 -90/ 900407-2"
" 3 9 -90/ 900407-1"
" 89 -9011/ 800408"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}