using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d?\s\p{L}*)\s(.*)";
string input = @"1 grębowska 33a/11
1 Maja 3/12a
Kwiatowa 1
Polska 1/1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}