$re = '/(\d?\s\p{L}*)\s(.*)/m';
$str = '1 grębowska 33a/11
1 Maja 3/12a
Kwiatowa 1
Polska 1/1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);