package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d?\s\p{L}*)\s(.*)`)
var str = `1 grębowska 33a/11
1 Maja 3/12a
Kwiatowa 1
Polska 1/1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}