const regex = /(\d?\s\p{L}*)\s(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d?\\s\\p{L}*)\\s(.*)', 'gm')
const str = `1 grębowska 33a/11
1 Maja 3/12a
Kwiatowa 1
Polska 1/1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}