// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d?\s\p{L}*)\s(.*)").unwrap();
let string = "1 grębowska 33a/11
1 Maja 3/12a
Kwiatowa 1
Polska 1/1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}