re = /(https?|ftp):\/\/[^ ]+/
str = 'טקסט שיש בו כתובות אינטרנט https://regex101.com/ ואני רוצה לחלץ את הדומיין למשל. http://tchumim.com/topic/1463/regex-%D7%91%D7%99%D7%98%D7%95%D7%99%D7%99%D7%9D-%D7%A8%D7%92%D7%95%D7%9C%D7%A8%D7%99%D7%99%D7%9D/3 וכמובן שהזכויות שמורות לתחומים.קום שהכתובת היא http://tchumim.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end