// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?|ftp):\/\/[^ ]+").unwrap();
let string = "טקסט שיש בו כתובות אינטרנט https://regex101.com/ ואני רוצה לחלץ את הדומיין למשל. http://tchumim.com/topic/1463/regex-%D7%91%D7%99%D7%98%D7%95%D7%99%D7%99%D7%9D-%D7%A8%D7%92%D7%95%D7%9C%D7%A8%D7%99%D7%99%D7%9D/3 וכמובן שהזכויות שמורות לתחומים.קום שהכתובת היא http://tchumim.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}