# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\h*\R\s*([^\s|])/ $1/gm;t' <<< "|123|;|ABC|;|text
text text|
|124|;|ABB|;|Text
text |
|125|;|BDD|;|text text text|
|126|;|ABC|;|text text
text
text|
|127|;|ABC|;|text text text|"