#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\h*\R\s*([^\s|])"
Local $sString = "|123|;|ABC|;|text " & @CRLF & _
"" & @CRLF & _
"text text| " & @CRLF & _
"" & @CRLF & _
"|124|;|ABB|;|Text " & @CRLF & _
"" & @CRLF & _
"text | " & @CRLF & _
"" & @CRLF & _
"|125|;|BDD|;|text text text| " & @CRLF & _
"" & @CRLF & _
"|126|;|ABC|;|text text " & @CRLF & _
"" & @CRLF & _
"text " & @CRLF & _
"" & @CRLF & _
"text| " & @CRLF & _
"" & @CRLF & _
"|127|;|ABC|;|text text text|"
Local $sSubst = " $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)