import Foundation
let pattern = #"\h*\R\s*([^\s|])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
|123|;|ABC|;|text
text text|
|124|;|ABB|;|Text
text |
|125|;|BDD|;|text text text|
|126|;|ABC|;|text text
text
text|
|127|;|ABC|;|text text text|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)