import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\h*\\R\\s*([^\\s|])";
final String string = "|123|;|ABC|;|text \n\n"
+ "text text| \n\n"
+ "|124|;|ABB|;|Text \n\n"
+ "text | \n\n"
+ "|125|;|BDD|;|text text text| \n\n"
+ "|126|;|ABC|;|text text \n\n"
+ "text \n\n"
+ "text| \n\n"
+ "|127|;|ABC|;|text text text|";
final String subst = " $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}