// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\h*\R\s*([^\s|])").unwrap();
let string = "|123|;|ABC|;|text
text text|
|124|;|ABB|;|Text
text |
|125|;|BDD|;|text text text|
|126|;|ABC|;|text text
text
text|
|127|;|ABC|;|text text text|";
let substitution = " $1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}