using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z][\w]+@[a-z]+.com$";
string input = @"rcedsRsa@gmail.com
rcedsEas1a@gmail.com
a11111111@gmail.com
asdasd123@asdas.com.br";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}