package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z][\w]+@[a-z]+.com$`)
var str = `rcedsRsa@gmail.com
rcedsEas1a@gmail.com
a11111111@gmail.com
asdasd123@asdas.com.br`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}