// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z][\w]+@[a-z]+.com$").unwrap();
let string = "rcedsRsa@gmail.com
rcedsEas1a@gmail.com
a11111111@gmail.com
asdasd123@asdas.com.br";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}