$re = '/^[a-z][\w]+@[a-z]+.com$/m';
$str = 'rcedsRsa@gmail.com
rcedsEas1a@gmail.com
a11111111@gmail.com
asdasd123@asdas.com.br';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);