package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([\w-]+)-\d{4}-\d{2}-\d{2}-\d{2}-\d{2}-\d{2}.gz$`)
var str = `repo-2019-12-31-14-30-11.gz`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}