const regex = /^([\w-]+)-\d{4}-\d{2}-\d{2}-\d{2}-\d{2}-\d{2}.gz$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w-]+)-\\d{4}-\\d{2}-\\d{2}-\\d{2}-\\d{2}-\\d{2}.gz$', 'gmi')
const str = `repo-2019-12-31-14-30-11.gz`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);