re = /^([\w-]+)-\d{4}-\d{2}-\d{2}-\d{2}-\d{2}-\d{2}.gz$/mi
str = 'repo-2019-12-31-14-30-11.gz'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result