import re
regex = re.compile(r"^([\w-]+)-\d{4}-\d{2}-\d{2}-\d{2}-\d{2}-\d{2}.gz$", flags=re.MULTILINE | re.IGNORECASE)
test_str = "repo-2019-12-31-14-30-11.gz"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)