#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/wp-admin/(?:network/|user/)?[\w-]+\.php$"
Local $sString = "/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php" & @CRLF & _
"/wp-admin/user/test.php" & @CRLF & _
"/wp-admin/other/test.php" & @CRLF & _
"/wp-admin/network/test.php" & @CRLF & _
"/wp-admin/test.php"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")