$re = '@^/wp-admin/(?:network/|user/)?[\w-]+\.php$@m';
$str = '/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php
/wp-admin/user/test.php
/wp-admin/other/test.php
/wp-admin/network/test.php
/wp-admin/test.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);