import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/wp-admin/(?:network/|user/)?[\\w-]+\\.php$";
final String string = "/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php\n"
+ "/wp-admin/user/test.php\n"
+ "/wp-admin/other/test.php\n"
+ "/wp-admin/network/test.php\n"
+ "/wp-admin/test.php";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}