re = /^\/wp-admin\/(?:network\/|user\/)?[\w-]+\.php$/m
str = '/wp-admin/LongFancy____-----Sitename___---Matches_My_Pattern.php
/wp-admin/user/test.php
/wp-admin/other/test.php
/wp-admin/network/test.php
/wp-admin/test.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end