package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)s:(\d+?):\\\"(https?:\/\/)?example\.com`)
var str = `a:5:{s:5:\"test1\";s:35:\"example.com\";s:5:\"test2\";s:26:\"foo http://example.com/bar\";s:11:\"submit_data\"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}