// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)s:(\d+?):\\\"(https?:\/\/)?example\.com"#).unwrap();
let string = "a:5:{s:5:\\\"test1\\\";s:35:\\\"example.com\\\";s:5:\\\"test2\\\";s:26:\\\"foo http://example.com/bar\\\";s:11:\\\"submit_data\\\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}