use strict;
my $str = 'a:5:{s:5:\\"test1\\";s:35:\\"example.com\\";s:5:\\"test2\\";s:26:\\"foo http://example.com/bar\\";s:11:\\"submit_data\\"}';
my $regex = qr/s:(\d+?):\\\"(https?:\/\/)?example\.com/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}