re = /s:(\d+?):\\\"(https?:\/\/)?example\.com/m
str = 'a:5:{s:5:\\"test1\\";s:35:\\"example.com\\";s:5:\\"test2\\";s:26:\\"foo http://example.com/bar\\";s:11:\\"submit_data\\"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end